Active Issue Alert – Blackbaud Altru - #000688687

Incident Report for Blackbaud

Resolved

This incident has been resolved.
Posted Aug 18, 2026 - 19:57 EDT

Investigating

An issue has been identified that may cause intermittent, brief network connectivity disruptions for US customers using Altru and CRM. Our team is actively working to implement a resolution and restore full-service stability
Posted Aug 18, 2026 - 19:37 EDT
This incident affected: Blackbaud Altru®.