Active Issue Alert – Raiser's Edge NXT - 000285895
Incident Report for Blackbaud
Resolved
This incident has been resolved.
Posted Sep 14, 2021 - 12:50 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 14, 2021 - 12:30 EDT
Investigating
We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted Sep 14, 2021 - 11:48 EDT
This incident affected: Blackbaud Raiser's Edge NXT® (Raiser's Edge NXT®).