Active Issue Alert -Online Giving/Donation Forms

Incident Report for Blackbaud

Resolved

This incident has been resolved.
Posted Feb 12, 2026 - 09:42 EST

Update

We are continuing to investigate this issue.
Posted Feb 12, 2026 - 09:42 EST

Update

We have identified an issue impacting some of our customers that would prevent them from editing Online Giving Standard Donation forms. Our engineers are working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates
Posted Feb 12, 2026 - 09:23 EST

Update

We are continuing to investigate this issue.
Posted Feb 12, 2026 - 09:22 EST

Update

We are continuing to investigate this issue.
Posted Feb 12, 2026 - 09:18 EST

Investigating

We have identified an issue impacting some of our customers that would prevent them from editing Online Giving Standard Donation forms. Our engineers are working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted Feb 12, 2026 - 09:10 EST
This incident affected: Blackbaud Altru®, Blackbaud CRM™ and Blackbaud Raiser's Edge NXT® (Raiser's Edge NXT®).