Active Issue Alert – Blackbaud ID – Multiple Products - #000085934
Incident Report for Blackbaud
Resolved
We recently resolved an issue that prevented users from signing in or using features in their solutions. You should now be able to sign in to your Blackbaud solutions and services with your Blackbaud ID.
Posted Nov 11, 2019 - 08:26 EST
Investigating
We identified an issue that may prevent you from signing in with your Blackbaud ID or using features in the solutions below. We’re working to diagnose and resolve the issue as quickly as possible. Please continue to check this page for updates.
Posted Nov 11, 2019 - 08:08 EST
This incident affected: Blackbaud Education Management Solutions (Blackbaud School Website System™, Blackbaud Enrollment Management System™, Blackbaud Learning Management System, Blackbaud Student Information System™), Blackbaud Grantmaking™ (Blackbaud Grantmaking™), Blackbaud Financial Edge NXT® (Accounts Payable API, Financial Edge NXT, General Ledger API, Statistical Unit API, Treasury API), Blackbaud Altru®, Blackbaud eTapestry®, ResearchPoint™, WealthPoint®, DonorCentral® NXT, Blackbaud Raiser's Edge NXT® (Constituent API, Fundraising API, Gift API, Opportunity API, Raiser's Edge NXT®), and Blackbaud Merchant Services™ (Payments API).