Our teams are seeing successful delivery of all emails that were impacted by this issue and remediation is now complete. Customer email campaigns and statistics should now be sending/reporting as intended. We will continue to monitor for any potential impact until 4:15 pm ET. Please continue to reference this page for updates.
Posted Dec 02, 2025 - 16:01 EST
Update
We continue to see successful delivery after resending emails impacted by an issue causing intermittent errors for a small percentage of email campaigns. While customers may see delays in some email sends and statistics, our teams hope to fully resolve this issue by 4 pm ET and will continue to monitor for any further impacts. Please continue to reference this page for updates.
Posted Dec 02, 2025 - 15:15 EST
Update
Our teams continue to work on an issue impacting a subset of customers that is causing intermittent errors for a small percentage of email campaigns and leading to some emails not sending. While we do not have a resolution at this time, we are attempting to resend the failed jobs to constituents who did not receive the initial emails. Please continue to reference this page for updates.
Posted Dec 02, 2025 - 14:29 EST
Investigating
We have identified an issue impacting a subset of customers that is causing intermittent errors for a small percentage of email campaigns and leading to some emails not sending. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Dec 02, 2025 - 12:44 EST
This incident affected: Blackbaud Luminate Online® (Blackbaud Luminate Online®) and Blackbaud Raiser's Edge NXT® (Raiser's Edge NXT®).